Information on the POODLE vulnerability

Update January 2015: Mimecast does not support web browser access over SSLv3 and we use an implementation of TLS that properly validates TLS padding. This prevents both the SSLv3 and TLS version of the POODLE vulnerability from being exploited on our platform.

Latest information on Mimecast services and why they are not affected by the POODLE vulnerability can be found on our Knowledge Base here.