Mimecast Confirms Services Are Unaffected by Heartbleed Bug

Mimecast can confirm that its services are secure and unaffected now, and in the past, by the recently reported OpenSSL vulnerability known as the Heartbleed Bug or officially CVE-2014-0160. Mimecast has never used OpenSSL to provide TLS/SSL encryption. There is therefore no need for customers to take any action on their accounts related to the Heartbleed Bug. If you have any questions about your account, please contact customer support.

FILED IN